< Back to All Knowledge Articles

File It Upgrade Required by November 11, 2016

  SpringCM Partners  Last updated: April 28, 2016     

SpringCM has recently released File It 4.4. This release includes a host of new features designed to make it easier for Salesforce Administrators to configure File It.  

SpringCM requires that all customers who are using File It upgrade to version 4.4 or greater by July 22, 2016 in their Sandboxes. Sandbox orgs that have not been updated to version 4.4 or greater by this date will have the update automatically deployed via Salesforce push update processes.

SpringCM requires that all customers who are using File It upgrade to version 4.4 or greater by November 11, 2016 in their Production/Development orgs. Production/Developments orgs that have not been updated to version 4.4 or greater by this date will have the update automatically deployed via Salesforce push update processes.

What is the schedule for this initiative?

  • July 22, 2016  - Customers will upgrade and test sandbox orgs with the latest package version. 
  • July 22, 2016 - Sandbox orgs remaining on older packages will be auto-upgraded by SpringCM at 9 pm CT.  
  • November 11, 2016  - Customers will upgrade and test production orgs with the latest package version. 
  • November 11, 2016  - Production orgs remaining on older packages will be auto-upgraded by SpringCM at 9 pm CT. 

Why is this happening?

  • SpringCM wants to ensure that all our Salesforce customers can take advantage of new functionality, bug fixes, and overall improvements.
  • This new version enables Salesforce Admins to more easily configure File It on standard and custom objects.
  • This new version includes a set of improvements required to use SpringCM Track It in Salesforce 1.
  • This new version includes a set of improvements required to integrate with SteelBrick. 
  • Upgrading to the most current version of the package ensures that Salesforce Administrators are able to easily configure their integration. Salesforce Admins will be able to take advantage of new capabilities as we enhance File It. 

What SpringCM packages are affected? 

The SpringCM File It package with the SpringCMEos namespace need to be upgraded to our most current version, version 4.4 or greater. To validate which package and version you have installed, check Installed Packages in App Setup. 

  • If you have the File It package with namespace SpringCMEos, then your org needs to be upgraded to version 4.4 or greater. 
  • If you have the File It package with namespace SpringCM2SF, then no changes or upgrades need to be done.

After this initial round of upgrades, we will keep File It and Track It up to date as well using Salesforce push update processes. As we make improvements and bug fixes, we will deploy these improvements in a coordinated effort.

Which package versions are affected? 

  • SpringCM File It 1.2
  • SpringCM File It 1.3
  • SpringCM File It 1.4
  • SpringCM File It 1.5
  • SpringCM File It 1.6
  • SpringCM File It 1.7
  • SpringCM File It 1.9
  • SpringCM File It 2.3
  • SpringCM File It 2.4
  • SpringCM File It 2.5
  • SpringCM File It 3.0
  • SpringCM File It 3.1
  • SpringCM File It 3.2
  • SpringCM File It 3.3
  • SpringCM File It 3.4
  • SpringCM File It 3.5
  • SpringCM File It 3.15
  • SpringCM File It 4.0

How do I upgrade File It? 

To upgrade File It perform the following steps:

  • Visit the AppExchange to download File It for Document Management by SpringCM.
  • Selet Get It Now. 
  • If prompted, Login to the App Exchange with your Salesforce credentials
  • Identify if you want to install the package in a production or sandbox org.
  • Confirm that you have read the terms and conditions and select Confirm and Install!
  • When prompted to choose which user(s) to install the FileIt(™) package for, select the appropriate audience. Normally this is Install for All Users but may vary depending on your use case.
  • Select the Install button.
  • You will see a dialogue asking you to Approve Third Party Access. Select  the Yes, grant access to these third-party web sites checkbox and click Continue.
  • Wait as it installs. When the installation is complete, click the Done button.

After the installation process has completed, begin testing. 

How do you know when it is done? 

You can check which version of the package is installed by looking at the Installed Packages page. After your upgade has been completed, File It version 4.4 or greater will be installed. 

How should I test this upgrade?

Before upgrading your org to the most current version of the package, please validate that SpringCM works as expected end to end.  As part of this testing exercise, perform the following tasks:

  • Load each object that File It is configured on and validate that the folder is created in SpringCM where you expect
  • Create new documents or folders in each new object. 
  • Test and validate that Doc Launcher or Doc Builder is setup and configured correctly
  • Test and validate that workflows get started as expected. 
  • Test and validate that Custom Actions are displaying as expected
  • Test and validate that User Sync perform as expected. 

After upgrading, repeat the same process to confirm that everything is working as you expect. 

Will I have to change Account, Opportunity, Case, or other configured objects?

No, you do not need to change any of your configured objects as a result of this upgrade.  Your end user's experience will not change as a result of this upgrade. 

What will be different after the package has been upgraded? 

  • Administrator Experience: The administrator experience is  significantly improved by this upgrade. File It configurations configured prior to this upgrade will not be changed.  This upgrade makes it easier on a go-forward basis for Administrators to modify and setup new configurations. 
  • User Experience: The user experience does not change with this upgrade. 

What happens with older versions of Get It?

  • If your org has 2.3, 2.4, or 2.5 installed, then Get It will still to work as expected. If you need to make changes to your configuration, then you may need to recreate the configuration.  
  • Version 3.0 and greater are unchanged. 

Why do I see a link to configure Get It when I did not before? 

  • Get It was introduced in version 2.3. Older version did not include Get It.  

What happens if I don't upgrade my org? 

If you do not upgrade your sandbox org by July 22, 2016 or your production org by November 11, 2016, SpringCM will automatically upgrade your org to version 4.4 or greater.

Where can I get the new version of the package?

The most current version of the package can always be found at the AppExchange Listing (https://appexchange.salesforce.com/listingDetail?listingId=a0N300000016coCEAQ) where you can click on Get It to install the upgrade. 

What should I do if I find an issue?

  • Should you identify an issue, please log a case with SpringCM and provide a description and detailed steps to reproduce the issue. 
  • Each issue will be triaged by SpringCM and a resolution will be provided.  Where necessary, we will issue a patch to the package and deploy. 

Who should I reach out to if I have questions?

Should you have any questions or concerns, please reach out to Customer Success about the program and about the process.